حل مشکل Metasploit require the bundler در Kali Linux

دوستان سلام
امروز می خواهم درباره مشکلی که شاید در آپدیت کالی لینوکس و در هنگام اجرای Metasploit برای شما به وجود بیاید با شما صحبت بکنم این مشکل که دلیل بر عدم نصب ورژن جدید Ruby زبان برنامه نویسی محبوب Metasploit می باشد به وجود می آید که یک مشکلی است که شما را گمراه میکند و به سمتی می برد که در حلش به مشکل می خورید که در این مقاله برای شما با یک تکنیک ساده حل می کنیم با ما همراه باشید...
خب همان طور که میدانید نرم افزار محبوب Metasploit به طور پیشفرض روی توزیع کالی لینوکس نصب هست و در هنگامی که ما داریم آن را Update می کنیم می آید Exploit ها خودش را از سایت محبوب Exploit-DB به روزرسانی میکند. احتمالا خیلی از دوستانی که مثل بنده علاقه خاصی به کار کردن با این نرم افزار بسیار عالی رو دارند در هنگام اجرا با این مشکل بر بخورند :
metasploit require the bundler


خب همین طور که می بینید با این مشکل در هنگام اجرا بر میخورید و مثل من خیلی از سایت های خارجی رو به دنبال حل این مشکل ورق میزنید و در آخر هم جوابی نمیگیرید حتی به سایت خود Bundle هم می روید و دستورات رو بعد از کلی کلنجار میزنید و در اخرش هم جوابی نمیگیرید و شاید هم خسته بشید و ی عالمه فحش بدید وایییییی این دیگه چه Error مسخره ای بودش که سد راهمون شد  خب نگران نباشید.
اول بگم خدمت شما که این مشکل بخاطر این است که Metasploit ای که آپدیت شده با نسخه قدیمی Ruby که روی سیستم شما نصب هست کار نمیکند و میخواهد که شما بیاید تنها Ruby رو آپدیت کنید و اصلا نیازی نیست بروید Bundler رو نصب کنید و کلی کار اضافه دیگه خب چطوری Ruby رو آپدیت کنیم به این شکل:
$ gem update --system # may need to be administrator or root
به همین سادگی و خوشمزگی ...
حالا بعد از این کار برید Metasploit خودتون رو اجرا کنید و با خیال راحت به کد نویسی خودتون ادامه بدید...
دوستدار همه شماها روح الله امینی
لطفا تا میتوhنید نشر بدهید.

#امنیت #bundler #کالی #bundle #metasploit #متااسپلویت #لینوکس
0 نظر

هیچ نظری ارسال نشده است! اولین نظر برای این مطلب را شما ارسال کنید...

نظر شما
برای ارسال نظر باید وارد شوید.
تنظیمات حریم خصوصی
تائید صرفنظر

امروز ارزان تر از فردا در جشنواره تخفیف ها

با بهترین ها یاد بگیرید